System error message

Incident Report for Microbizz

Resolved

We have solved the problem where our customers encountered an error message while logging onto their systems, and are monitoring the situation.
Posted Aug 29, 2025 - 07:00 CEST

Investigating

Most of our customers are currently experiencing an error message when trying to connect to Microbizz. We are on the case and expect to resolve the issue before 07:00 CET
Posted Aug 29, 2025 - 06:35 CEST
This incident affected: Systems (System16, System17, System18, System19, System20, System21, System22, System23, System24, System25, System26, System27, System28, System29, System32, System33, System34, System35, System36, System37, System38, System39, System40, System41, System43, System44, System45, System47, System48, System49, System50, Demo).